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Create layout templates
When a professional layout program is to be used by beginners or documents are to be exchanged
between several users, fundamental questions arise:

• How can I, as a beginner, work with a professional layout program without overwhelming myself
or investing time in training?

• How can I, as a professional user, prepare documents for beginners without overwhelming the
beginner?

• How can I, as a professional user, ensure that a beginner does not make any unwanted changes?
When you share documents between multiple users, all users usually have the same editing options,
because they use the same program. This means that anyone can make any change. There is no effec-
tive protection against unwanted changes..

However, if you are a beginner and want to work with a professional layout program, or if you are a
professional user and want to provide documents to beginners, this can be problematic. Most of the
time, beginners are overwhelmed by the multitude of options, even though the task may be quite sim-
ple for the user. In addition, the beginner can make unwanted changes at any time.

The answer to all these issues is to limit the editing options.

The great advantage of VivaDesigner is not only that you can use it on the desktop and on the web, but
also that you can individually limit the editing options of the program or even of a single document.
Thus, even a user who has never worked with a professional layout program will not be overwhelmed
and can focus directly on his task. The restrictions apply to all areas of the program such as docu-
ments, pages, objects, images, texts, tables and palettes.

We call such a document a layout template.

This section we explains what options are available for creating layout templates and what should be
considered when creating layout templates.

Editing options
The central option for creating layout templates is restricting the editing options. To restrict the editing
of documents there are several options that work additively:

• Working mode

• Access rights

• Passwords for Alias pages and layers
In the Working Mode, three options are available across the board: Beginner, Advanced and Expert,
each of which allows a predefined selection of options. While all the program's options are available to
users in the Expert work mode, the user cannot, for example, visualize text style sheets in the Beginner
work mode.The options can be set independently of documents for the program or for the role in Viva-
Cloud.

In terms of access rights, there are over 30 options that control, for example, the editing of text or
objects in detail. So the options refer either to individual documents or to a role in VivaCloud.
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You can protect individual Alias pages or layers with a password. This option is useful, for example, if
you want to give the document to several translators, but they should always have access only to the
layer with the respective language.

All the options can be combined, which means that the Beginner work mode cannot visualize text style
sheets, even if this right is not restricted by the access rights. In return, the user cannot create objects in
the Professional working mode if this option is locked via the access rights. A user who basically has
an access to layers can edit only the layers which are not assigned with a password or from which he
has the password.

The lowest common denominator applies in each case. This is especially true if access rights are
defined both for the document and via the role in VivaCloud.

Work mode and access rights are available both on the desktop and on the web.

Working Mode
Choose Preferences > Program >Working Mode if you want to restrict document editing across the
board. If you want to use this option in VivaCloud, choose the appropriate option in the role.

See the Preferences section for more information.

Access rights
Chooose Preferences > Access Rights if you want to restrict editing for all users. Users who want to
remove this restriction need a password.

Please refer to the section Working in a Team.

It is also possible to restrict access rights in VivaCloud for each role separately. This option is dynamic,
which means that a user with the "Graphic Designer" role may have more editing rights than users with
the "Student" role. The access rights defined in VivaCloud apply to all documents stored in VivaCloud,
regardless of whether they are edited in the browser or opened using the desktop version.

Both options can also be used in a combination. For example, if it is determined that no role should be
able to create additional document pages, this option could basically be saved with the document, but
could also be defined with each role. Which way to choose depends on whether the document editing
is done via VivaCloud or locally. If the documents are stored locally on a desktop computer, the access
rights must be defined in the document. Once VivaCloud is used, we recommend defining access rights
using the role in VivaCloud only.

Passwords
In the Pages palette, click the desired Alias page in the list and select Protect Alias Page in the context
menu if you want to protect the Alias page with a password. The Alias page is displayed when you
double-click the name even if you do not know the password, but you can no longer edit it.

Select Unprotect Alias Page from the context menu and enter the password if you want to unprotect
the Alias page.

In the Layers palette, click the desired layer in the list and choose Edit Layer in the context menu and
then Lock Layer > Password Protect if you want to password protect the layer.
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Click the lock icon in the Layers palette and enter the password if you want to unprotect the Alias page.

If you forget the password, the Alias page or layer is no longer editable.

Tips for layout templates

Introduction
Restricting the editing options, however, also implies that certain aspects have been taken into
account when building a layout, so that later editing is also possible.

With a few exceptions, it doesn't matter whether you built the layout in VivaDesigner or another pro-
gram (such as Adobe InDesign) and then imported it into VivaDesigner. The process is always the
same:

Step 1: – Think about a concept of what editing options you want to give a user for a document. Each
document and user role can have different editing options.

Step 2: – Implement the concept in the layout. For existing documents, check whether the concept has
been implemented in all points.

Step 3: – Set the editing options for the program, document and/or role in VivaCloud.

Step 4: – Check the functionality of the editing options to ensure that all desired options are available
to the user.

General tips
When creating layout templates, always consider what editing options are available to the user. For
example, if users

• cannot create their own pages and/or objects, all necessary pages and/or objects must already be
available in the document.

• cannot stretch objects, all text objects must be created to accommodate the required amount of
text.

• cannot move objects, the layout must be built/adjusted in such a way that the position of depen-
dent objects results automatically.

• cannot make individual markups of texts, all necessary style sheets must already exist in the docu-
ment.

• also cannot mark up texts using style sheets, corresponding sample texts must exist and already be
marked up.

With this in mind, you may need to modify the structure of existing documents without changing the
layout. When creating and preparing layout templates, you should always keep in mind that another
user

• must be able to find his way around your document without familiarization when editing it,

• has fewer functions for editing the document, depending on the access rights,

• and should only modify the document in the way you intend.
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The user will only find his way around your document if he can immediately recognize which functions
are available to him. This applies to working with pages, objects, texts, style sheets or images.

Therefore, consider whether it makes sense to allow users to select options such as presets and
change colors & gradients or style sheets at all.

Tips on document pages
• Remove all unnecessary document pages.

• Remove all unnecessary Alias pages, if the user has access to the Pages palette.

• Choose the display mode for Alias pages and document pages in the Pages palette.

• Optionally protect Alias pages with a password.

Tips on objects and layers
• Delete all objects on the working area to avoid confusing the user.

• Objects that are repeated on different pages and should not be edited can be placed on Alias
pages.

• All other objects that should not be edited or printed can either be protected or placed on special
layers and locked.

• Alternatively, you can place all objects to be edited on one layer and lock all other layers. In either
case, you also do not need to password protect the layer unless you allow the user to select a
layer. However, make sure that when you save the document, the layer that you want the user to
edit later is also selected.

• Note that not all desktop editions have the Layers palette.

• Optionally, choose View > Visualize Locked Objects to show the user which objects they can edit
at all.

• Optionally, help texts can be placed on locked and non-printable layers. Help texts can also be
defined for an object or text using the option Window > Notes. When the mouse pointer is moved
over the object, the note appears in a tool tip.

Tips for graphic and image objects
• When working with background images, it is often helpful to place them on a separate layer that

will be locked later.

• The background images should also be optimally adapted to the size of the image object in order
to reduce the amount of data.

• In addition, you should avoid image objects that are placed over a double page if the page is also
needed individually. Therefore, such motifs should be composed of two image objects for left and
right side

• Select the option Preferences > Pages & Objects > Objects > Embed all used images. This option
is mandatory so that the image data imported by the users is fully embedded in the layout docu-
ment.
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• In many cases, your design will already contain predefined image objects with placeholder images.
Users can import their own images into these image objects. When you import a new image into
an image object containing an existing image, the scale factor of the previous image is applied.
Since you don't know how big these new images will be, this can lead to unsightly effects. There-
fore, we strongly recommend using the options White Space Optimization and Fill Frame Auto-
matically. These options ensure that there will be no flash between the frame and the image
(white space will not appear) and that the images will always fit perfectly into the image object.

• In many cases, there is also the question of whether images can be stretched. Images that have a
fixed size should be fixed and not editable in size. In addition, you can use the Interaction Rules to
determine whether for example an image object can be moved only vertically and/or stretched
only vertically.

• If you choose the option Fill Frame Automatically, the image will automatically resize itself when
the image object is enlarged and will also be enlarged. However, when the image is scaled down,
the scaling value is preserved. The user must then use the scaling handle to scale the image object,
if it is also available based on the interaction rules.

• Graphic objects should be created as graphic objects and not as empty image objects. Otherwise,
the impression is created that images can/should be imported into these objects.

Tips for text objects
• Create appropriate text objects and define which objects may be fixed and which may be

stretched. Optionally specify the options for stretching objects with the Interaction Rules, Lock
and/or Protect options in the Object menu .

• Consider a concept for sample texts. Check whether you already fill the text objects that the user is
to edit with sample texts and how you want to mark them up. Keep in mind that all texts that the
user does not delete or revise will be output later

• Choose Text > Character Options > Options > Placeholder Text if you have entered a sample text
that should be selected completely with one mouse click. The option is applicable to any character.

• Consider a concept for a dynamic layout. Check if the layout adjusts automatically when the user
enters more or less text:

• Headings and a text following them should not be entered in separate text objects if the length of
the heading is variable.

• Images should be anchored in the text if the position of the image depends on the amount of text.

• If texts are to be framed, a separate text object is not always necessary. Alternatively, you can also
define a background and/or a frame with any text.

• Select GREP styles and/or nested styles if the user's input is to be automatically marked up accord-
ing to a certain pattern.

• Images and texts can be placed in tables with a fixed height, so that the height of the images
adjusts to the amount of text. To do this, you need to set the line height for texts to Auto and the
line height for images to 100%.

Tips for style sheets
• Use style sheets to mark up text if you want the user to mark up text using style sheets only. Using

the View > Visualize Text Style Sheets option, you can quickly check which texts have been
marked up with style sheets.
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• Use style sheets to mark up objects as well. This allows you to quickly adjust all objects afterwards.

• Use style template names that identify the function. Names such as “Headline”, “Body text” are
more useful than “Arial-12/14”.

• If possible, use the style sheet names predefined in the program if the document should be used in
different countries. These names are automatically translated by the program when the program
language is changed.

• Create paragraph style sheets for left justified, right justified and/or character style sheets for
bold, italic, superscript, subscript if such attributes are to be used in the text and if the Module
palette is turned off.

• Consider whether users should have the right to change style sheets.

Tips for fonts
• Choose Preferences > Embedded Fonts > Embed all fonts used. This option is mandatory if the

document is edited on the web or on operating systems where the fonts used are not installed.

• Choose Preferences > Embedded Fonts > Disable System Fonts if you do not want users to select
other fonts, provided they have permission to select fonts in principle. This option is not mandatory,
but is recommended for security reasons, even if users can only format text using style sheets.

• When opening documents, all fonts must be available.

• Missing fonts can refer to the text, style sheets or settings in presets, even if they are not used.

• VivaDesigner may display missing fonts even though they are actually installed in the system. This
can be the case if these fonts originate from a different operating system and the naming is inter-
preted minimally differently under the current system. In some cases, fonts in InDesign and in
VivaDesigner have slightly different font names, which can lead to the message. In these cases, fol-
low the instructions in the dialog and replace the fonts accordingly.

• If you do not want to install the missing fonts in the system, you can also drag and drop the respec-
tive font individually onto the document. The program will provide feedback if the font was
imported successfully. However, this requires that the option Embed all used fonts is selected.

• When you open an InDesign document, for technical reasons, missing fonts are not displayed until
the document is saved in VIVA format and reopened.

Tips for imported templates from InDesign
You can also use existing InDesign documents as templates. Basically, the same rules apply to InDesign
as to the program, provided that these options are also available in InDesign. For more information,
please refer to the section Exchange with InDesign.
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