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Working in a Team
Depending on the edition/license, the program has a number of options that
allow multiple users to work together worldwide and across languages. This
includes the collaboration of several users in the sense of an editorial system, as
well as the collaboration between media service providers and end customers.

Overview of the team functions

Editing of documents

Multilingualism and Translations
The program offers multilingual user guidance in over 20 languages, as well as automatic translation of
colors and style sheets when certain rules are followed. You can enter texts in all languages and, if nec-
essary, translate them fully automatically into several target languages.

Change Tracking
With the option Change Tracking you can establish who has made which changes in a document. The
program creates a report with the exact time and which text was inserted, deleted or newly formatted
by whom.

Notes
With the option Notes you can store nonprintable information and notes for other users for texts and
objects.

Restrict document editing
• TheWorkingMode options generally restrict the editing of documents. Please refer to the
Preferences section.

• The Access Rights options restrict the editing of individual documents. Please refer to the section
Working in a Team.

• The Protect Alias Pages option prevents the editing of individual Alias pages with the help of a
password prompt. Please refer to the section Working with Pages.

• Die Option Ebenen schützen verhindert mithilfe einer Passwortabfrage die Bearbeitung einzelner
Ebenen. Beachten Sie hierzu den Abschnitt „Arbeiten mit Ebenen“.

These options are especially useful if you want to create documents that other users should edit only
according to certain criteria or users have little or no knowledge of layout programs.

Tasks
With the option Tasks can be used to organize documents so that several users can work on a docu-
ment at the same time.
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Libraries
With the option Libraries, parts of documents can be saved and re-inserted into other documents. All
styles and colors are preserved. Please refer to the notes in the Libraries section.

Embedded Fonts
With the option Embed All Used Fonts you can share documents with other users who do not have
these fonts and cannot or do not want to install them. Please refer to the notes in the section Prefer-
ences.

Embedded Images
With the option Embed All Used Images you can embed all the images used in the document. This
option is especially useful when users import images into the document that are not accessible to
third parties, but still need to create printable documents. Please refer to the notes in the Preferences
section.

Document Management

Drives
With the option Drives you can save documents to databases or Internet drives and edit them directly.
They can establish connections to image databases from various manufacturers and optionally force
the user to import images only from these drives. Please refer to the notes in the Preferences section.

VivaCloud
With VivaCloud a web-based system for the administration of documents and files (Asset Management
System MAM) of all types is optionally available to you, which can also be used as an editorial system.

Collection
With the Collection option, you can combine individual documents into a complete work (book,
magazine, journal, etc.). This option works on local drives, network drives or also Internet drives (e.g.
VivaCloud). Please refer to the notes in the section Working with Collections.

Status information
With the help of status information in VivaCloud, you can control exactly which processing stage your
documents are in. The status information is also displayed in collections.

Package & Send (VIVA FileSender)
Using the option Package & Send (VIVA FileSender) you can send a document to VIVA or to a specified
address with all fonts and images fully automatically. You do not need an e-mail or FTP program to do
this. To send the data to an address other than VIVA, you need an appropriate communication profile,
which is available on request. Please refer to the notes in the Export section.
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Change Tracking
With change tracking you can establish who has made which changes in a document. The program
creates a report with the exact time and which text was inserted, deleted or newly formatted by whom.
Change tracking is therefore suited for users who work in a team, or for users who only want to create a
report protocol of their work.

Activate/Deactivate Change Tracking
You can activate change tracking at any time, and deactivate it either temporarily or permanently.

Activate/Deactivate Change Tracking
1. Choose View > Track Changes (Operating System Design) or Text > Track Changes (Neutral VIVA

Design).

• Alternatively, choose the option Track Changes in the context menu.
If you deactivate change tracking, you can edit the document without any changes being marked.
Deactivating change tracking will not remove any changes that were already marked. If you copy text
containing changes marked by change tracking, the change tracking attribute will also be copied
although change tracking was deactivated.

Display of changed text passages
Different text changes are marked in different colors by the Change Tracking:

- Deleted text will not be removed from the text, but instead will be displayed in red with a
strikethrough.

- Inserted text will be displayed in blue and underlined.

- Changed attributes (e.g. assignment of style sheets, changes to font size, etc.) will be displayed
with a yellow background.

Furthermore, a red correction bar will be displayed at the edge of the line. You can change the display
for the current document in the Preferences at any time.

Accept/Reject changes
With the Change Tracking option you can check all changes and decide if you want to accept or reject
them. For each change the Date, Time and Change Type are displayed. Insofar as it is available, the
Author who made the changes will be displayed.

Accept or reject changes
1. Choose the option Window > Track Changes.

2. Choose one of the following actions:

• Click Next to spring to the next change.

• Click Previous to spring to the previous change.
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• Click Accept to accept a change. The program then springs automatically to the next change. It
may occur that with the next change the same text passage is marked if two text changes were
made simultaneously. This is for example the case when a text is inserted and then formatted as
well.

• Click Accept All if you want to accept all changes without any checking.

• Click Reject to reject a change. In this case all the newly inserted text will be deleted automatically
and any formatting changes will be cancelled.

• Click Reject All if you want to reject all changes without any checking.

Changing the preferences for change tracking
With the Preferences you can define the Author name and the display of the altered text passages.

Define the Author Name
1. Choose the option Edit > Preferences > Program > General (Windows/Linux) or
{Application} > Preferences > Program > General (Mac).

2. Enter the required name in the Author field.

Note: Please note that the name is used not only for change tracking, but also for other options (e.g.
Notes).

If you are using VivaDesigner in the Web Edition, particularly with VivaCloud, you should not enter a
name for the author, as the author’s name changes with the user. In such cases the name of the author
can be transmitted during the session.

Define display of changed text passages
1. Choose the option Edit > Preferences > Text > Change Tracking (Windows/Linux) or
{Application} > Preferences > Text > Change Tracking (Mac).

2. Choose one of the following actions:

• Choose Activate Change Tracking to activate change tracking using the
Preferences.

• Choose options for Deleted Text, Inserted Text, Changed Attributes: Strikethrough, Underline,
Background Color or Foreground Color. If you choose the option None, the text changes will be
invisible. In this case you can still use the Change Tracking palette to spring to each change and
accept or reject it.

• Choose a color of your preference for Deleted Text, Inserted Text and Changed Attributes.

• Choose Left border or Right border to define on which side of changed lines a correction bar
should appear. Choose None if no correction bar should appear.
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Notes

Create Notes
With the Notes function you can apply non-printable information and tips for other users to text and
objects. Like change tracking, this option is suited for users who work in a team or for users who only
want to create a report of their work.

Create a Note for an object
1. Choose and select an object.

2. Choose Object > Note in the menu or Note in the context menu.

3. Enter the note in the entry field.

4. Confirm your entry.

Create a Note in a text
1. Place the cursor at the point in the text where the note will be set.

2. Choose one of the following options:

• Press Alt + N (Windows/Linux) or Option + N (Mac).

• Choose Text > Note (Operating System Design) in the menu or click the Note symbol (Neutral VIVA
Design).

• Choose Note in the context menu.

3. Enter the note in the entry field.

4. Confirm your entry.
A note is symbolised with a red speech bubble.

Change a Note for an Object
1. Select the Object containing the Note.

2. Choose Object > Note in the menu or Note in the context menu.

3. Change the note in the entry field.

4. Confirm your entry.

Change a Note in text
1. Place the cursor at the point in the text where the note is set.

2. Choose one of the following options:

• Press Alt + N (Windows/Linux) or Option + N (Mac).

• Choose Text > Note (Operating System Design) in the menu or click the Note symbol (Neutral VIVA
Design).

• Choose Note in the context menu.

3. Change the note in the entry field.

4. Confirm your entry.
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Managing notes
With the Notes option, you can check all the notes and decide if you want to change or delete them.
For each Note the Creation Date and Change Date with the appropriate Time are displayed. Insofar as it is
available, the Name of the Author who made the changes will be displayed.

1. Choose Window > Notes.

2. Choose one of the following actions:

• Click Next to spring to the next note. If only one note is available, a further click on Next will have
no effect.

• Click Previous to spring back to the previous note.

• Click Remove to delete a note.

3. Click in the entry field and change the note. The change will be accepted if you click Next or Previous,
or if you click anywhere in the document.

Changing preferences for notes
You can change the name of the Author in the Preferences.

Define the Author Name
1. Choose Edit > Preferences > Program > General (Windows/Linux) or {Application} > Preferences >
Program > General (Mac).

2. Enter the required name in the Author field.

Please note that the name is used not only for notes, but also for other options (e.g. Change Tracking).
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Access Rights
The editing of documents can be limited for third parties using access rights. This function is particu-
larly helpful if as a user you want to create documents that other users are only allowed to edit accord-
ing to certain criteria. These users should for example only have the possibility of entering text or mov-
ing images. As the creator of the documents you protect them with an individual password and you
can unlock the documents with the password to edit them yourself.

In addition to the access rights described below, the program also offers the options “Working Mode”,
“Protect Alias Pages” and “Protect Layers”. Please refer to the notes in the sections Preferences,Working
with Pages andWorking with Layers.

Tip: Use the Access Rights if you want to individually restrict the editing of a document in the desktop
workflow. Use the Working Mode if you generally want to restrict the editing of documents in the desktop
workflow. Use the access rights and/or working mode if you want to restrict the editing of documents in
the web workflow.

Basic working methods

Static Access Rights (desktop workflow)
If other users edit the documents in a desktop version, you can restrict the editing using the access
rights but in this case you must assign a password. Without the assignment of a password, the options
have no effect. Passwords for layers or Alias pages are not affected.

The access rights options affect the desktop version immediately when you assign a password, confirm
the settings and save the document. You may also need to open the document again (File > Revert to
Saved). Users who do not have a program version for unlocking access rights or who do not know the
password can only edit the document according to the criteria that have been set. To unlock the docu-
ment for complete editing, you need the assigned password. Therefore, it can be helpful to back up the
document without a password, because if you forget the password, it can not be unlocked by anyone!
Furthermore, consider a concept by which you assign the password or always assign the same pass-
word for all documents. Thus you will make editing easier.

If other users edit the documents on the desktop with a certain version, you may under certain circum-
stances be able to dispense with certain access rights as these options are not included in this edition.
The Free Edition does not include any options for layers, for example. Therefore you don’t need to
assign any password protection to individual layers.

Dynamic Access Rights (Web workflow)
If other users edit the documents in a Web version, you may be able to dispense completely with set-
ting access rights and assigning passwords in the document (for example in the VivaCloud). Passwords
for layers or Alias pages remain unaffected. In the Web version, all the access rights can be assigned
dynamically using an XML snippet. The parameters for this are listed in the following section.

Example:

<vivaDocAccess xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:noNamespaceSchemaLocation="Access.xsd">

<option name="search-replace-palette">true</option>
<option name="spell-check-palette">true</option>
<option name="character-inspector-palette">false</option>
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</vivaDocAccess>

Depending on the application, this assignment may be carried out with relation to user roles. Dynamic
assignment works basically according to the same rules as the static assignment in the document, with
the exception that the assignment of a password is superfluous.

Static and Dynamic Access Rights (Web workflow)
If you have assigned access rights both in the Web application and in the document, the relevant
options are only available if they are not deactivated in both cases. This function is helpful if you apply
a certain basis access right to a user group (e.g. Move Objects) but do want to switch this right off for a
single document.

Create/Unlock Access Rights

Create access rights for a document
1. Choose Edit > Preferences > Access Rights.

2. Choose one of the options described in the section Options for Access rights.

3. Click the Password button.

4. Enter a password in the Password entry field and repeat the entry in the next entry field. Choose the
option Make visible to display the password in clear text on the screen.

5. Confirm the entry.

Change access rights for a document
1. Choose Edit > Preferences > Access Rights.

2. Choose one of the options described in the section Options for Access rights.

3. Click the Password button to optionally apply another password.

4. Confirm the entry.

Unlock access rights temporarily/permanently

1. Choose File > Unlock Access Rights.

2. Enter the password.

3. Optionally choose Unlock permanently.

4. Confirm the entry.

Options for Access Rights
The name of the option usually corresponds to the name of the option of the same name in the menu.
Please refer to the operation of each option in the relevant sections of the manual. Therefore, only gen-
eral information, in particular interaction with other options, is described in this section.

For these preferences the same rules apply as those for all other preferences. This means: All options
are only valid for the current document. If no document is open, then the settings will be valid for all
new documents.
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Options for Program
You define general access rights for the program in the Program dialog area.

• Menubar — Steers the display of the program menu. This option is useful if you want to provide an
extremely minimalist interface. With this option, you should be aware that it is not possible to
select any options via a menu afterwards. Therefore, all necessary options (Save, Exit, etc.) should
either be available in corresponding toolbars or you have to start the document via the emergency
mode. Please refer to the notes in the section Starting the program (emergency mode. If you use
the option as part of a dynamic access right (e.g. via VivaCloud), i.e. the access right is not part of
the document and is assigned dynamically when the document is opened, there is no need to
open the document in emergency mode.

• Custom Document Toolbars — Steers the display of personalised document toolbars in the Pref-
erences. (Parameter: “document-custom-toolbars”).

• Custom Program Toolbars — Steers the display of personalised program toolbars created in the in
the Preferences. (Parameter: “program-custom-toolbars”).

Options for Newmenu
You define access rights for the New menu in the New dialog area. In the Web Edition, this option is
only useful if the New option is selected in the Preferences.

• Document — Allows the creation of new documents. (Parameter: “new-document”).

• Document from Template — Allows the creation of new documents from a template (e.g. in the
VivaCloud). (Parameter: “new-document-from-template”).

• Collection — Allows the creation of new collections. (Parameter: “new-collection”).

• Library — Allows the creation of new libraries. This option only makes sense if the option Library is
permitted in the section Toolbars and Palettes. (Parameter: “new-library”).

Options for Documents
You define general access rights for the document in the Document dialog area.

• Save — Allows the saving of documents. This option is only useful if the user has the appropriate
writing rights. (Parameter: “save”).

• Save As — Allows documents to be saved under a different name. This option is only useful if the
user has corresponding writing rights. If no option to save the document is selected, the document
can not be saved. This is helpful, for example, if the user is only allowed to make changes and to
print, but the source document is not to be changed. (Parameter: “save-as”).

• Import — Allows all options for importing texts, images, objects and fonts to be switched on and
off.

• Text (Dialog) — Allows the import of text files via the import dialog. This option is only useful if the
Edit Text option is selected. (Parameter: “import-text-dialog”).

• Text (Drag & Drop) — Allows the import of text files via drag & drop. This option is only useful if the
Edit Text option is selected. (Parameter: “import-text-drag”).

• Images (dialog) — Allows the import of image files via the import dialog. This option is only useful
if the Images option is selected. (Parameter: “import-images-dialog”).

• Images (Drag & Drop) — Allows the import of images via the import dialog. This option is only use-
ful if the Create Objects option is selected. (Parameter: “import-images-drag”).
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• Objects — Allows the import of object files via drag & drop. This option is only useful if the Images
option is selected. (Parameter: “import-objects”).

• Fonts — Allows the import of fonts via drag & drop. This option is only useful if the Edit Text option
is selected. (Parameter: “import-fonts”).

• Document Setup — Allows you to edit the document settings. This option is only useful if the
option Objects is selected. (Parameter: “edit-document-settings”).

• Preferences — Allows you to edit the preferences. This option is only useful if the user is allowed to
change ALL preferences. There is the danger that a user in the desktop version can change the
access rights if he knows the password. In the Web Edition this is prevented if the access rights are
applied dynamically (e.g. VivaCloud). (Parameter: “edit-preferences”).

• Colors —Allows the editing of colors. This option is only useful if the option Edit Objects and/or
Edit Text is selected.(Parameter: “edit-colors”).

• Style Sheets — Allows the editing of Style Sheets. This option is only useful if the option Edit
Objects and/or Edit Text is selected.(Parameter:“edit-style-sheets”).

• View — Steers the display of the View menu. (Parameter: “view-menu”).

• Zoom — Steers the display of the Zoom menu. (Parameter: “zoom-menu”).

Options for Libraries
You define the library options for the document in the Library dialog area. These options only make
sense if the option Library is permitted in the section Toolbars and Palettes.

• Open — Allows the creation of a new library. (Parameter: “open-library”).

• Add Item — Allows elements to be added to a library. (Parameter: “add-library-item”).

• Delete Item — Allows elements to be deleted from a library. (Parameter: “delete-library-item”).

Options for Output
You define the output options for the document in the Output dialog area. These options are only use-
ful if the user has the appropriate writing rights. Please note that the options for the output in Viva-
Cloud are controlled via separate settings.

• Printing — Allows the printing of documents. In the Web Edition, the document can be printed on a
local printer. (Parameter: “printing”).

• PDF Export — Allows the document to be exported as a PDF file. This option is only useful if the
user has corresponding writing rights. This option has no effect on editions that do not have PDF
Export (for example, “Free Edition”). (Parameter: “pdf-export”).

• EPS Export — Allows the document to be exported as an EPS file. (Parameter: “eps-export”).

• PS Export — Allows the document to be exported as a PS file. (Parameter: “ps-export”).

• JPEG/PNG/SVG Export — Allows the document to be exported as a JPEG, PNG or SVG file. (Param-
eter: “image-export”).

• Text Export — Allows the document to be exported as a text file. (Parameter: “text-export”).

• Object Export — Allows the export of objects as an XML file. (Parameter: “object-export”).

• High Resolution Output — The complete image data is used for the output. This option is only
useful if the images are embedded in the document or if access to the original images is possible.
(Parameter: “hires-output”).

11



Working in a Team | Access Rights

Options for Objects
• Objects — Allows switching on and off all options for the editing of objects.

• MoveObjects— Allows objects to be moved. If the option is selected, the corresponding tool will be
displayed if the Tools option is also selected. Otherwise, the object can be moved without the
Tools palette. (Parameter: “move-objects”).

• Stretch Objects — Allows objects to be stretched. (Parameter: “stretch-objects”).

• Edit Paths — Allows the editing of paths. If the option is not selected, no new paths can be created,
selected or deleted.

• Modify Objects — Allows the editing of object coordinates, colors or contour settings. (Parameter:
“modify-objects”).

• Create Objects — Allows the creation of objects. This option is only useful if the if the Tools option
is also selected.(Parameter: “create-objects”).

• Delete Objects — Allows objects to be deleted. (Parameter: “delete-objects”).

Document page options
• Document pages — Allows you to switch all options for editing document pages on and off.

• Create — Allows document pages to be created. (Parameter: “create-document-pages”).

• Delete — Allows document pages to be deleted. (Parameter: “delete-document-pages”).

• Move — Allows document pages to be moved using the option in the Document menu, as well as
in the Pages palette. (Parameter: “move-document-pages”).

• Settings — Allows you to change the settings of document pages. This includes the option Docu-
ment Page Settings and Margins & Columns.(Parameter: “document-page-settings”).

Alias page options
• Alias pages — Allows you to switch all options for editing Alias pages on and off.

• Apply — Allows you to interactively apply Alias pages to document pages using the Pages palette.
(Parameter: “apply-alias-pages”).

• Create — Allows the creation of Alias pages. (Parameter: “create-alias-pages”).

• Delete — Allows the deletion of alias pages. (Parameter: “delete-alias-pages”).

• Settings — Allows you to change the settings of Alias pages. This includes the Alias Page Settings
option as well as Margins & Columns. (Parameter: “alias-page-settings”).

Note: If you want to block the editing of Alias page content, choose the Protect Alias Page option.

Text options
• Text — Allows the switching on and off for all options for editing text.

• Edit Text — Allows the editing of text (input, deletion, replacement, etc.). The possibilities a user
has for formatting text depend on the options Module and Style Sheets. (Parameter: “edit-text”).

• Track Changes — Allows change tracking to be displayed in the text. If the option is not selected,
the settings in the document apply. This option is only useful if the Edit Text option is selected.
(Parameter: “text-track-changes”).

• Text Invisibles — Allows the display of invisible control characters. If the option is not selected, the
settings in the document apply. (Parameter: “text-show-invisibles”).

12



Working in a Team | Access Rights

• Insert Special Character — Allows the insertion of special characters. If the option is not selected,
the settings in the document apply. (Parameter: “text-insert-char”).

• Insert Break — Allows the insertion of break or wrap characters. If the option is not selected, the
settings in the document apply. (Parameter: “text-insert-break”).

• Insert Space — Allows the insertion of characters for blank spaces.If the option is not selected, the
settings in the document apply. (Parameter: “text-insert-space”.

• Insert Hyphen/Dash — Allows the insertion of hyphens or dashes. If the option is not selected, the
settings in the document apply. (Parameter: “text-insert-hyphen”).

• Insert Variable — Allows the insertion of variables. If the option is not selected, the settings in the
document apply. (Parameter: “text-insert-variable”).

• Insert Object — Allows the insertion of objects. If the option is not selected, the settings in the doc-
ument apply. (Parameter: “text-insert-objects”.

• Ruby Text (furigana) — Allows the insertion of Ruby text. If the option is not selected, the settings
in the document apply. (Parameter: “text-insert-ruby”)

Options for Pictures
• Pictures — Allows the editing of images (change image crop, scaling, etc.). The option can be lim-

ited by other options (e.g. Modify Objects or Import Pictures). (Parameter: “edit-pictures”)

Options for Tables
• Tables — Allows the editing of tables (columns, rows, cells, etc.). The option may be restricted by

other options (e.g. Modify Objects or Module). If the option Module is not selected, the table set-
tings can only be selected with the context menu. If the option Modify Objects is not selected, only
single cells and no table rows or columns may be selected.

• Create Tables — Allows the creation of new tables. (Parameter: “create-tables”).

• Change Tables — Allows tables to be changed. (Parameter: “change-tables”).

• Edit Tables — Allows the editing of table content. (Parameter: “edit-tables”)

Options for displaying toolbars and palettes
With the options in the Toolbars & Palettes dialog area, you define which palettes can be displayed. If
an option is not selected, the palette will be hidden automatically when switching between documents
with different settings, and the appropriate options will either be hidden or grayed out in the Window
menu.

• Tools — Please note that not all tools may be displayed. The display of individual tools can be lim-
ited by other options (e.g. Create Objects or Move Objects). (Parameter: “tools-toolbar”).

• Navigation — Please note that not all options may be displayed. The display of individual options
may be restricted by other options (e.g. Manage Pages). (Parameter: “navigation-toolbar”)

• Quick Access — Please note that not all options may be displayed. The display of individual
options can be restricted by other options (eg Edit Text). (Parameter: “module-toolbar”)

• Neutral Design — This option is only useful if the Neutral Design option is selected in the
Preferences. Please refer to the notes in the Preferences section. The palette allows the selection
of character and paragraph style sheets independently of the Style Sheets option. (Parameter:
“neutral-design-toolbar”)
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• Module — The option determines not only the display of the palette, but also of the associated
menus (object, text, images, table, etc. ). Please note that not all options may be displayed. The
display of individual options may be restricted by other options (eg Edit Text). (Parameter: “module-
palette”)

• Pictures — This option is only useful if the option Edit Pictures is selected. (Parameter: “picture-
palette”)

• Layers — If the option is not selected, you cannot switch between several layers. In this case, new
objects will be created on the selected layer. This option is only useful if at least one option under
Edit Objects is selected. (Parameter: “layer-palette”)

• Assignments — This option is only useful if the Edit Objects option is selected. This option is not
required for editing a task file. (Parameter: “assignments-palette”)

• Pages — Please note that not all options may be displayed. The display of individual options can
be restricted by other options (e.g. Manage Pages. (Parameter: “page-palette”)

• Colors — This option is only useful if the options Modify Objects and/or Edit Text are selected,
(Parameter: “color-palette”)

• Style Sheets — This option is only useful if the options Modify Objects, Edit Text and/or Pictures
are selected, (Parameter: “style-sheets-palette”)

• Search & Replace — This option is only useful if the option Edit Text is selected. The Search &
Replace options work independently of the options for formatting text. Therefore a user could
exchange fonts or Style Sheets, although he is not allowed to do this by other options. (Parameter:
“search-replace-palette”)

• Spell Check — This option is only useful if the option Edit Text is selected. (Parameter: “spell-
check-palette”)

• Character Inspector — This option is only useful if the option Edit Text is selected. (Parameter:
“character-inspector-palette”)

• Change Tracking — This option is only useful if the option Edit Text is selected. Parameter:
“change-tracking-palette”)

• Text Formatting Inspector — This option is only useful if the option Edit Text is selected. (Parame-
ter: “formatting-inspector-palette”)

• Notes — This option is only useful if the options Modify Objects and/or Edit Text are selected.
(Parameter: “notes-palette”)

• Trapping — This option is only useful if the option Modify Objects is selected. (Parameter: “trap-
ping-palette”)

• OpenType — This option is only useful if the option Edit Text is selected. (Parameter: “opentype-
palette”)

• Library — This option is only useful if the options for Library are selected. (Parameter: “library-
palette”)

• Help — This option is only useful if a Help text is available. (Parameter: “library-palette”)
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Access Rights in the Web Edition
In the Web Edition, you can define additional options for editing documents. These options are helpful
if the documents themselves have no (static) access rights or the web application used (e.g. a simple
website) does not offer the option of assigning access rights dynamically, as is the case with VivaCloud,
for example.

The access rights are applied hierarchically in a web edition in the following order:

1. General options for the Web Edition

2. Static access rights

3. Dynamic access rights

4. Document settings

Examples based on the option New:

• If the New option is selected in the Web Edition options, it no longer matters whether it is selected
in other access rights. It is then not possible to create new documents via the menu.

• If the New option is activated in the Web Edition options, the static access rights determine
whether the New option can be selected. Otherwise, the dynamic access rights (e.g. via the Viva-
Cloud) determine whether the New can be selected. If neither static nor dynamic access rights are
defined, new documents can be created via the menu.

The name of the option usually corresponds to the name of the option of the same name in the menu.
Please refer to the relevant sections of the manual for information on how the individual options work.
This section therefore only describes general information, in particular interactions with other options.

When setting the defaults, e.g. via the VivaDesigner-Server, no documents may be open and the
instances must be restarted so that changes are applied.

Setting Access Rights in the Web Edition
1. Choose Edit > Preferences > Program >Web Edition.

2. Choose the options according to the instructions in the following sections.

3. Confirm the entry.

Options for server communication
Use the options in the Server Communication dialog area to define the session duration and what
should happen to the document when a session expires.

• Interval for sending the session status — Allows the minimum time for a session to be defined in
minutes. The value “5” means that after 5 minutes of inactivity, the program will display a message
that the session will end in 60 seconds if the user does not perform any action. This option is useful
to prevent users from opening a document and then blocking the Web Edition instance for a long
time without actively working on the document.

• Automatically save documents when ending the session — Allows documents to be saved auto-
matically at the end of the session. This option is helpful if, for example, a user accidentally closes
the browser window and therefore no longer has access to the document. However, the user
should wait a few minutes until the document is released again, as it is only released after the end
of the session in accordance with the specified minutes.
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General Options
Use the options in the Options dialog area to define the menu options.

• Menu bar — Allows the menu bar to be displayed. This option is activated by default. Please refer
to the option of the same name in the section Options for Access Rights.

• Show language selection in the start dialog — Allows a language selection to be displayed.

• Replace “Quit Program” with “Quit Session” — Allows the Quit Session option to be displayed.
This option is activated by default so that users do not confuse the Quit Program option with clos-
ing the browser.

• Help — Allows the Help menu to be displayed. This option is deactivated by default, as this menu
contains options that generally make no sense in a web edition.

• Custom document-related toolbars — Allows the display of document-related toolbars. This
option is activated by default. Please refer to the option of the same name in the section Options
for Access Rights.

• Custom program-related toolbars — Allows the display of program-related toolbars. This option is
activated by default. Please refer to the option of the same name in the section Options for Access
Rights.

Options for the File menu
Use the options in the File options to determine the display of options in the File menu. Please refer to
the option of the same name in the section Options for Access Rights.

• New — Allows the option of the same name to be displayed in the File menu. This option is deacti-
vated by default, as documents are usually created via the web application.

• Open — Allows the option of the same name to be displayed in the File menu. This option is deac-
tivated by default, as documents are usually opened via the web application.

• Recently opened documents — Allows the option of the same name to be displayed in the File
menu. This option is deactivated by default, as documents are usually opened via the web applica-
tion.

• Revert to Saved — Allows the option of the same name to be displayed in the File menu. This
option is deactivated by default, as documents are usually opened via the web application.

• Close — Allows the option of the same name to be displayed in the File menu.

• Package & Send — Allows the option of the same name to be displayed in the File menu. This
option is deactivated by default, as this menu contains options that generally make no sense in a
web edition.

• Close — Allows the option of the same name to be displayed in the File menu.

• Import — Allows the option of the same name to be displayed in the File menu.

• Unlock Access Rights — Allows the option of the same name to be displayed in the File menu. This
option is deactivated by default, as this menu contains options that generally make no sense in a
web edition.

• Document Setup — Allows the option of the same name to be displayed in the File menu.

• Print — Allows the option of the same name to be displayed in the File menu.
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Options for the Edit menu
Use the options in the Edit Options dialog area to determine the display of options in the Edit menu.
Please refer to the option of the same name in the section Options for Access Rights.

• Colors & Blends — Allows the option of the same name to be displayed in the Edit menu.

• Style Sheets — Allows the option of the same name to be displayed in the Edit menu.

• Program Language — Allows the option of the same name to be displayed in the Edit menu. This
option is deactivated by default, as the program language can be transferred dynamically by the
web application when the web edition is opened.
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