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Introduction
With Database Publishing, you can automatically create both simple and highly complex designs
based on a data source and a set of rules. This includes not only print-ready business stationery such
as business cards or letterheads, but also entire catalogs, price lists, brochures, flyers, posters, packag-
ing, financial reports, resumes, logos or advertisements for print and social media channels can be cre-
ated automatically. The prerequisite for this is a corresponding document that can be used as a data-
base publishing template and a VIVA Database Publishing Server that creates these corresponding
designs based on the template.

In this section, we explain how to create a simple database publishing template for a web form from
any VivaDesigner or InDesign document in just a few seconds. You can use the VIVA Database Publish-
ing Server directly, via VivaCloud or any web application (e.g. website, CMS, store or web-to-print sys-
tem).

Innovations
The introduction of version 11 has dramatically simplified template creation for users and integration
of the software for developers:

New features on the user side
1. Users do not necessarily need the “Database Publishing Designer” for simple designs, which can be

used to create both simple and highly complex templates.

2. Users can create templates for the first time with VivaDesigner, as well as directly with InDesign.
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3. The manual creation of so-called CP forms can be omitted. The creation of these shapes is fully
automatic based on the design. This also applies to all associated settings in the presets and the
cancel rule.

4. The manual creation of so-called XMP blocks for the definition of the web form can be omitted. The
creation of the XMP block is fully automatic based on the design.

New features on the developer side
The integration of the VIVA Database Publishing Server into a web application could be reduced by 90%:

• The programming to create a form based on the XMP block can be completely omitted. The pro-
grammer only has to pass the corresponding document with the desired parameters for the form
to the VIVA server and manage the result (export).

• The programmer no longer has to create and manage export definitions (PDF, JPG, etc.). So-called
“export presets” can be stored directly on the server for the respective project. Any number of
export presets can be defined. The programmer can optionally determine which export presets are
available in which situation.

Create a simple template
To use a VivaDesigner or InDesign document as a template, simply replace the corresponding text (fig-
ure left) with the name of a variable enclosed in curly brackets (figure right). You can freely choose the
name of the variable. However, avoid special characters or spaces for variables. If the document has
several pages, change the texts only on the desired pages. You can use a variable with the same name
several times in the document, but the formatting may be different in each case. Nevertheless, the web
form displays the variable only once.

For example, in the document, the text “Create your perfect seminar” has been replaced with the
variable “{Headline}”.The name “Headline” will also appear as the field name in the web form.
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All static texts will be preserved. This is especially true for texts and images that come from sample
pages. In the document this is the text “Your Benefits” and “Visit us at our website”.

Define text variables

1. Choose one of the options below:

• Open the VivaDesigner document in VivaDesigner.

• Open the InDesign document in InDesign or in VivaDesigner.

2. Note that the name of the document determines the title of the web form.

3. Replace the respective text with the desired variables in the text in curly brackets.

4. Follow the notes and instructions in the Technical notes for VivaDesigner templates section if you
created the template in VivaDesigner, or Technical notes for InDesign templates if you created the
template in InDesign

5. Save the document.

ShowWeb Form

1. Choose one of the following options to display the web form:

• Server URL — If you have direct access to a VIVA Database Publishing Server, enter the following
URL in the browser: {server name}/{project name}/form/. Note the optional parameters in the
Information for Web Page Creators section here , which allows you to specify the selection and
layout of the web form

• Viva website — Open the Viva website and choose “Test” in the Database Publishing section.

• VivaCloud — If you have a VivaCloud account and a corresponding license to edit forms, save the
document to VivaCloud first. Choose Create Form Template from the context menu. VivaCloud
automatically creates a form document in the same folder with the same file name and “.nwpd”
extension. Double-click the new document with the “.nwpd” file extension to display the web form.

• Web application — If you are using a web application that integrates a VIVA Database Publishing
Server (e.g. CMS, store, or web-to-print system), please follow the appropriate instructions for that
application

2. Fill out the web form. In the so-called “live mode”, the results are displayed immediately when you
use the tab key or click with the mouse pointer in another input field. If the “live mode” is not active
or if you do not want to leave the current input field, choose Update Preview to display the result.
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The display of the input formsmay vary depending on the application and corresponding settings.
Therefore, these representations are only an example.

3. Choose Export to export the design in a specific format (PDF, JPG, etc.)

Please note that the chosen application determines whether and which export options are available.

Technical notes for VivaDesigner templates
Determine how to handle images and fonts used:

• All standard Windows operating system fonts are installed on the VIVA servers. Google fonts are
also automatically detected. If you additionally use other fonts, they can be installed on the VIVA
server depending on the license. Choose the Embed all used fonts option if this is not possible or
useful. Alternatively, you can transfer the fonts to the server together with the template. Please
refer to the instructions in the section Working with ZIP archives.

• Choose the Embed all images option if the images used are not available on the server

Technical notes for InDesign templates
When you create your template in InDesign, the document is converted to a native VIVA format using
the VIVA Database Publishing Server. Both programs have thousands of options and an almost identi-
cal basic concept and are therefore almost identical. Nevertheless, there are crucial differences. There-
fore, during the conversion, there may be differences in the design that cannot be avoided. On our
website we have listed the differences between VIVA and InDesign. Please note the information in the
section Opening InDesign documents.

Basically, you should observe the following notes in your InDesign template (as of May 2023):
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• Make sure that text objects are not too small. Text objects should be at least one millimeter larger
in width and height to avoid text overset.

• Do not use nested objects, where you copy one object into another object to mask it, for example.
Convert such objects to images and place them again in the layout.

• Do not use effects that do not exist in VivaDesigner. If in doubt, convert such objects to images and
place them again in the layout.

• If possible, embed all images or create a ZIP file with all images and fonts. See the instructions in
the section Working with ZIP archives.

• Make sure that you are authorized to use the fonts on another computer. You can test this in InDe-
sign by using the File > Package option. If fonts are missing in the process, you will need to check
the licensing terms and may need to purchase the missing font elsewhere or replace it with a paid
or free alternative (e.g. Google Fonts).

• All standard fonts of the Windows operating system are installed on the VIVA servers. Google fonts
are also automatically recognized. If you additionally use other fonts, these can be installed on the
VIVA server depending on the license. Since this is not possible or useful in many cases, the fonts
can also be transferred to the server with the template. Please refer to the notes in the section
Working with ZIP archives.

Advanced form options

Additional options for text variables
In some cases you may want to change the input and display of the web form. In the example, this may
be the case if you want to specify default texts or help texts, or if you want to determine the order in
which the fields are displayed in the web form.

1. Choose one of the options below:

• Open the VivaDesigner document in VivaDesigner.

• Open the InDesign document in InDesign or in VivaDesigner.

2. Replace the respective text you with the desired variables in the text in curly brackets.

3. Position the mouse pointer between the last character of the variable and the closed curly bracket.

4. Choose one of the options below:

• VivaDesigner - Choose Text > Note, or Window > Notes

• InDesign - Choose Window > Notes, and then choose New Note.

5. Enter one or more of the options described below:

• Label — Defines the field label in the form. This option is useful if you do not want the name of the
variable in the text to match the field label in the form. This may be the case if you have used very
short field names in the text due to space limitations. For example: “Label:Telephone”, while the
variable in the text is “Fon”. If no label is defined, the name of the variable in the text will be used
automatically.

• Order — defines the order of the field in the form. This option is useful if the order of the fields in
the form does not correspond to the order in the text. If you define this option for only one field, all
other fields will automatically appear in the order of the text. Therefore, it may be useful, but not
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mandatory, to use this option for all fields. (Example “Order:2”). Only positive numbers are
allowed. It does not matter if they show gaps (e.g. 2, 4, 20). If no order is defined, the order of the
variables in the text is automatically used.

• Type — defines the field type. Allowed values are “text”, “number”, “email” and “url”. This option is
useful if you want to explicitly set a field type other than the default “text”. The type “text” allows
the input of all characters, the type “number” allows only the input of digits, the type “email”
allows only the input of a syntactically correct mail address, the type “url” allows only the input of
a syntactically correct web address. Example: “Type:text”. If no field type is defined, the value
“text” is set automatically.

• Default — Defines a default value that will be displayed in the field. This option is useful if you want
to explicitly set a default value. Example: “Default:USA”. The string “USA” will be displayed in the
field and will be used automatically if the user does not specify another value. It would also be
conceivable to have a variable as the default value. For example, the default value “$Username$”
could ensure that the name of the logged-in user automatically appears in the form.

• Placeholder — Defines a placeholder text that will be displayed in the field. Example: “Default:En-
ter your name”. The string is displayed in the field but not used in the output.

• Description — Defines a description text that is usually displayed below the field. Example:
“Description:Please use uppercase letters only”

• Pattern — Defines a pattern for input to the web form. The pattern is defined as a regular expres-
sion. Example: “Pattern:[0-9]{4}”). A maximum of four digits from 0-9 can be entered here.

• Prefix — Defines the prefix of a field, which means a text that always appears BEFORE the field.
Example: “Prefix:(”.However, the “(”string appears only if the field also has a content. You can
also format the prefix with a character style sheet. To do this, specify the name of the style sheet in
the format “Prefix:@{StyleName}:{Prefix}”. Specifying “Prefix:@Blue:(” will color the bracket
blue if this color is defined in the “Blue” style sheet. In a prefix you can also use control characters like
“<\d>” for paragraph end and “<\n>” for line end.

• Postfix — Defines the postfix of a field, which means a text that always appears AFTER the field.
Example: “Postfix:)”. The string “)” will only appear if the field also has a content. You can also
format the postfix with a character style sheet. To do this, specify the name of the style sheet in the
format “Postfix:@{style name}:{postfix}”. Specifying “Postfix:@Blue:)” will color the paren-
thesis blue if this color is defined in the “Blue” style sheet. In a postfix you can also use control
characters like “<\d>” for Paragraph break and “<\n>” for Forced Line Break.

Defining image variables
In our example, you want to change the background image. To do this, we need to create a variable for
the image object.

1. Create corresponding image objects and optionally import corresponding images. These images will
be displayed by default and will be overwritten only when corresponding images are replaced.

2. Choose the name for all variable image objects. Replace the name of the image or image object in
the Layer palette with the name of the variable. Again, write the variable in curly brackets. This name
will be used as the variable and as the label.

3. Choose the object, and then choose one of the options below:

• VivaDesigner — Choose Object > Note.
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• InDesign — Choose Object > Object Export Options, and then Alt Text > Custom.

4. Enter one or more of the options described below:

• Label — Defines the field label in the form. This option is useful if you don't want the name of the
object in the Layer palette to match the field label in the form. For example: “Label:Picture 1”,
while in the Layer palette there is only “{Pic1}”. If no label is defined, the name of the variable in the
Layer palette is automatically used

• Order — defines the order of the field in the form. This option is useful if you want to define the
order of the fields in the form (example “Order:2”). Only positive numbers are allowed. It does not
matter if they have gaps (e.g. 2, 4, 20). If no order is defined, the order of the variables in the palette
level is automatically used

• Type — defines the field type. Allowed values are “upload” and “text”. This option is useful if you
want to explicitly set a field type other than the default “upload” value.The value “upload” creates
an option for a file selection in the form. This option is useful if you want the user to upload images
himself. The value “text” creates an input field for text in the form. This option is useful if the user
should only enter the name of the image because it is already on the server. One way to transfer
the variable images to the server is to use the “ZIP archive” option. Please refer to the section
Working with ZIP archives. Example: “Type:text”. If no field type is defined, the value “upload” is
set automatically

• Description — Defines a description text that is usually displayed below the field. Example:
“Description:Please select your own image”

Define image behavior for VivaDesigner templates

1. Click in the image object

2. Choose Module > White Space Optimization to ensure that imported images are not displayed with
a white space

3. Choose Edit > Preferences > Pages and Objects > Fill Frame Automatically to ensure that imported
images are fully fitted

4. Choose Edit > Preferences > Pages and Objects > White Space Optimization to ensure that
imported images are not displayed with a white space in new image objects

5. For the note, enter one or more of the options described below:
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• Fitting — Defines the scaling of imported images independently of the previous options. The
“fit-to-frame” value corresponds to the Fit Picture to Frame option . The value ”proportional”
corresponds to the option Fill Frame Proportionally. The value “zoom-to-frame” corresponds to
the option Fit Picture Proportionally to Frame. The value”100%” corresponds to the option 100%.
All values between “5%” and “400%” are allowed.Example: “fitting=zoom-to-frame”

• Alignment — Defines the alignment of imported images independently from the previous options.
The value “left-top”, “left-center” and “left-bottum” align the images to the left. The value
“right-top”, “right-center” and “right-bottum” aligns the images right. The value “top-center”,
“center” and “bottum-center” align the images centered. Example: “alignment=left-top”.

Define image behavior for InDesign templates

1. Choose Object > Fit > Frame Fitting Options to specify how variable images are fitted to the object

2. Choose Auto Fit.

3. Choose a suitable setting. For example, for logos that you want to display in their entirety, choose Fit
Images Proportionally.For photos, you can also choose “Fill Frames Proportionally” and the
appropriate alignment

4. Choose Object > Display Performance > High Quality to get good quality images in the preview.
This option can be preset in InDesign's preferences for all new documents.

5. In the Links palette , choose Embed Link to embed an image file in the document. Another option
for transferring static and variable images to the server is the ZIP Archive option. Please refer to the
notes in the section Working with ZIP archives. However, we recommend embedding at least the
static images.

Working with ZIP archives
A “ZIP archive” (abbreviation of the English word “zipper”) is a file format in which several files and/or
entire directories can be combined, or archived, in a single file with the file extension “zip”.

Instead of using a single VivaDesigner or InDesign document, you must create a ZIP archive if you want
to ensure that the fonts and images used in the document are used for display and print output.

You can avoid creating a ZIP archive only if

• all fonts used are installed on the server

• only Google fonts are used
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• all fonts are embedded in the document (VivaDesigner only)

• all images used are embedded in the document

• variable images are uploaded separately

Create a ZIP file with VivaDesigner templates.

1. Choose File > Package & Send.

2. Follow the instructions in the Package and Send section .

Create ZIP file with InDesign templates.

1. Choose File > Package to create a copy of the current document with all fonts and/or images in the
document.

2. Choose the appropriate options. Google fonts may or may not be used, as the server downloads
them dynamically.

3. Choose the folder in the operating system.

4. Choose the option in the operating system that allows you to package a folder as a ZIP archive.

General notes on ZIP archives

• Opening documents from ZIP archives takes longer than opening documents normally.

• A ZIP archive can contain all VIVA and InDesign document formats (e.g. indd, indt, idml) that can be
opened by VIVA. If a ZIP archive contains several documents, only the document found first will be
opened. Therefore, you should use only one document format in the ZIP archive if possible.

• ZIP archives that are in turn located in the ZIP archive to be opened are ignored.

• If fonts are missing after opening a document, they will be searched for in the ZIP archive and
installed automatically.

• The installation of fonts from the ZIP archive is temporary, so that these fonts are automatically
uninstalled after the document is closed.

• If the program finds other fonts in the same folder when searching for missing fonts, these fonts
will also be installed automatically. Therefore, you should only use the fonts in the ZIP archive that
are also used by the document.

• The temporarily installed fonts are only available to the document opened from the ZIP archive.

• The automatic installation of the fonts is not a guarantee that all missing fonts will be replaced cor-
rectly. Check the document for missing fonts before printing or PDF export.
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Complex web forms
In some cases, you may want to create very complex web forms that go well beyond the options
described earlier. For example, you might want to create forms with custom QR codes or drop-down
lists. Such complex web forms cannot be created directly with InDesign. You can create an InDesign
document as described and then edit it using the Database Publishing program, which is optionally
available as a desktop or web version.

Information for web page creators
Controlling a VIVA Database Publishing Server to create a web form is extremely simple and can be
done by anyone who can build a web page or enter a URL in the browser:

Enter the following URL in the browser:

https://{server_name}/{project_name}/form/?{parameter_1}&{parameter_2}&{parameter_3}

Server name — URL/IP address of the server (e.g. “myserver.com” or “192.00.00.00”)

Project name — On the server there are several projects where templates, documents, images or other
information are already stored

Form — Mandatory instruction for the server that the job is a form

Parameters — optional parameters that determine the selection of the template and the form display.
The order of the parameters is optional. Before first parameter starts with a “?”, every other parameter
with a “&”.

Parameter description
The description of the parameters is described in detail in the Server API. Below are only the most
important parameters:

generateForms — Converts the document into a form. Allowed values: “true” or “false”. The default
value is “false”. Example: generateForms=true

template-name — name of the template to be used for the form that already exists on the server. If
there is no template on the server, use the “Upload” parameter. Example: template-name=mytemp-
late.desd for VIVA documents or template-name=mytemplate.indd for InDesign documents

upload — Allows the user to upload a template to the server. Allowed values: “true” or “false”. The
default value is “false”. The web form will be calculated based on this template. If you want to use a
template that is already on the server, use the “template-name” parameter. Example: upload=true

show-title — displays the template name as a title in the form. Allowed values: “true” or “false”. The
default value is “true”. Example: show-title=true

columns — sets the number of columns in which the input fields are displayed. Allowed values are
integers between “1” and “5”. The default value is “1”. Example: columns=2

label-position — Determines the display of the input field labels. They can be left in front of the input
field (left), above the input field (top) or in the input field (floating) . Example: label-posi-
tion=top
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live-previews — Determines whether the preview should be calculated automatically after each
change between the input fields (true) or only after manual request (false). Allowed values: “true” or
“false”. The default value is “false”. Example: live-previews=true

preview-style — determines how and which pages of the template should be displayed. Allowed val-
ues: “all”, “all-vertical”, “all-horizontal”, “all-auto”, “single” or “scroll”.The default value is
“scroll”, which means that the user has to scroll when viewing multiple pages

preview-position — sets the position of the preview. Allowed values: “left”, “right”, “top” or “bottom”.
The default value is “right”. Example: preview-position=top

Examples

In this example, the document is to be uploaded by the user. The instruction is:

https://{server-name}/{project-name}/form/?upload=true&colums=2&preview-position=top
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In this example, the preview should be displayed on the left and the labels in the input field. The state-
ment is:

https://{server-name}/{project-name}/form/?upload=true&colums=2&preview-position=left
&label-position=floating
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